Heartbleed Vulnerability Update

A major security flaw, dubbed “Heartbleed”, was detected this week in OpenSSL - the encryption standard used by the majority of websites and services on the internet.

We took immediate steps to patch the potential vulnerability in our infrastructure, and Fleetio is no longer vulnerable.

We have no evidence of any malicious behavior, but we strongly encourage you to change your Fleetio password. We also recommend you change your passwords everywhere else, since this vulnerability affects many services and websites you use.

Please shoot us an email if you have any questions or concerns.

comments powered by Disqus